AI Zone Admin Forum Add your forum
LiunxChatScript64 don’t execute on linux server
 
 

I use chatscript 7.55 version(git clone) and ubuntu(aws)

when linuxChatScript64 run…. error

error messege.->

ubuntu@ip-172-31-2-37:~/chatbot/ChatScript/BINARIES$ ./LinuxChatScript64 local
./LinuxChatScript64error while loading shared librarieslibcurl.so.4cannot open shared object fileNo such file or directory 

why can’t run?

 

 

 
  [ # 1 ]

maybe install curl can fix the problem ?

apt-get install curl

 

 
  [ # 2 ]

you havent installed libcurl on your machine

 

 
  [ # 3 ]
Bruce Wilcox - Oct 11, 2017:

you havent installed libcurl on your machine

thank you.. i renamed “libcurl_gnutls_.so.4” —> “libcurl.so.4”
and i Solved!!!

 

 
  login or register to react