AI Zone Admin Forum Add your forum

NEWS: survey on 3000 US and UK consumers shows it is time for chatbot integration in customer service!read more..

ChatScript on a Mac

I have always run ChatScript on a Windows machine but I have a need to try and get it running on a Mac. I have been unsuccessful so far but I know little about the Mac OS.

If any are experienced with running ChatScript on a Mac and are willing to help, I would greatly appreciate it. Or if there are easier ways to run ChatScript using a Mac (using a VM or something like that) I am open to that.

I have some students who will work on my project but they all own macs.




  [ # 1 ]

I run CS on a Mac successfully.

You don’t quite mention what the issue is, whether it is compiling the executable or a run time issue. So some common things are:

The memory allocated by the Mac OS is slightly different and there tends to be more instances of memory violations. Fixes for those should be in the latest version of CS. In a twist I am not actually running this version, but my changes are there.

By default the Mac is compiled as a server, so if running locally like Windows then you’ll need to add the “local” command line parameter.


  [ # 2 ]

Hi Andy,

It would be compiling the executable. I have downloaded my project to the Mac. Not the absolute most recent version but not too old. I can easily update to the newest version if required.

I have managed to get to the Terminal window and am trying to figure out the terminal-specific commands (I am comfortable with the windows/dos command line).

That’s about as far as I have gotten.

Thanks in advance for any help.



  [ # 3 ]

The latest version, 10.2, has an updated Xcode project in the NON-WINDOWS NON-C/XCODE folder.
Just opening that project in Xcode and building should work.


  [ # 4 ]

Thanks Andy,

I am making progress but not quite there. Downloaded 10.2, opened the project in Xcode, edited the project settings as per the readme in Xcode, built, seemed to build fine, but then never could get “MacChatScript local” to start CS in the terminal window.

Do I also have to perform these maneuvers below as described in the \NON-WINDOWS Non-C\MAC folder readme file?

1 Copy from the MAC directory to the top level ChatScript directory
1a Insure Curl librarys are installed on your machine: OR
1b disable Json functions by #define DISCARDJSON 1 or similar compiler directive
2 Run MacCompile in a terminal window
3 In terminal window run ./BINARIES/ChatScript local to try it out



  [ # 5 ]

If you are opening the project in Xcode and compiling from there, then you should be good to go.
Your Mac probably already has curl installed - I got a new machine just recently and I have didn’t download curl. So shouldn’t need to change any of the compiler directives.

I run CS in two different ways.
1) from a terminal window: cd to the CS root directory and then ./BINARIES/MacChatScript local
2) from Xcode: have to make sure “local” is a launch argument for the scheme. Edit the scheme (Product | Scheme | Edit) and for Run there is an Arguments panel. Once that is saved, the Command-R will run the executable. Any problems might be connected to the working directory, CS prefers that to be the CS root.

When you say it doesn’t start, does anything appear in response to the command?


  [ # 6 ]

Thanks Andy,

I have it working from terminal now! I think I just wasn’t in the correct directory.

Now I just gotta transfer all my Windows build/files to this macBook.

Thanks again for all your help.



  login or register to react