AI Zone Admin Forum Add your forum

NEWS: survey on 3000 US and UK consumers shows it is time for chatbot integration in customer service!read more..

no such bot error

I am new to chatscript. I downloaded and compiled it on mac and got ./BINARIES/ChatScript executable.

Now I run it as:
/BINARIES/ChatScript local

It runs and prompt for user name:
Enter user name:

and when I enter my name, I get following error:

No such bot

Even in server mode, I get the same error.

Am I missing some steps?


  [ # 1 ]

A build failed.  To insure you can get it correct, you can do this
1. empty the contents of TOPIC (dont remove the folder)
2. :build 0
3. :build Harry   (or whatever bot you are using


  [ # 2 ]

Bruce as per your suggestion, I tried following:

:build 0
:build Harry

Harry started to chat to me. Thanks a lot for help.

I got Java client as per: but to use that I have to run chatscript in server mode, right?

So I did following:

./BINARIES/ChatScript server

and I get following messages:
og:1 userlog: 1
Server ready - logfile:LOGS/serverlog1024.txt serverLog:1 userLog:1

But how to run do :build Harry here. I don’t think program does anything when I do following:

Server ready - logfile:LOGS/serverlog1024.txt serverLog:1 userLog:1

:build 0
:build Harry

I think I am missing some basic understanding here. What is the good document to learn how to setup chatscript bot in server mode?



  [ # 3 ]

In windows the executable defaults to local mode and can be set to server mode as ChatScript port=1024
In linux/mac, it defaults to server mode and can be set to local mode as ./ChatScript local

You want to do :build 0 and :build Harry in local mode, but the std CS release already comes with the TOPIC folder properly built, so it SHOULD be unnecessary unless you have changed data in RAWDATA.

You need CS to be in server mode to interact with a client.


  [ # 4 ]

Hello Bruce,

Thanks for writing and sharing such a wonderful project. I am facing similar problem, let me describe what I am doing.

CS Version: CS6.91

1) I downloaded the ChatScript version and ran
2) I started ./BINARIES/ChatScript local mode.
3) Then I executed :build 0 and then :build Harry.
4) I am able to converse correctly chat bot.

5) Then I started ./BINARIES/ChatScript to run in server mode.
6) The server started correctly.
./ChatScript port=1024 interface=
ChatScript Release Version 6.91 pid: 0 64 bit MACH compiled Dec 10 2016 13:03:43 host=
WordNet: dict=201377 fact=85709 stext=12704304 Dec07’16-14:44:33
  Dictionary building disabled.

======== Began server 6.91 compiled Dec 10 2016 13:03:43 on host port 1024 at Sun Dec 11 20:04:40 2016 serverlog:1 userlog: 1
Server ready - logfile:LOGS/serverlog1024.txt serverLog:1 userLog:1

7)  Then I ran the php script

8) The webpage is opening correctly.But whenever I type “Hi ” in chat box, I get this in response. Bot: No such bot.

9) I typed :build 0 and :build Harry in the chat box but after that also still getting the same response.

Can you please help me with this as I am stuck because of this. I tried finding tutorial for setting chatscript server but could not find anything. Please help



  [ # 5 ]

Back up to basics. 

In standalone mode (nonserver) do :build 0 and then :build Harry.

If that is not the machine of your server, transfer the TOPIC folder to your server.  Then run your server in local mode by going to BINARIES and then running ./ChatScript local.  See if that works.

When that works, then run your server as a server and then from a different command window run a local client for it like:  ./ChatScript client=localhost:1024 .  See if that connects. I presume it will

That means the server is working and your problem is somehow with the webpage/php.


  login or register to react