AI Zone Admin Forum Add your forum
Compiling ChatScript on a Mac

I am trying to compile ChatScript on a Mac but am having some problems. I tried compiling using

g++ mainSystem.cpp 

but am getting this error:

ldsymbol(snot found for architecture x86_64
ld returned 1 exit status 

I tried also compiling in 32-bit, but to no avail:

ldsymbol(snot found for architecture i386
ld returned 1 exit status 

So the question is: is it possible to succesfully compile ChatSript on a Mac?



  [ # 1 ]

I don’t understand you trying to compile (and link) a single file.

Chatscript compiles under Windows, Linux, Mac, Ios, Android.

My Linux compile command while standing in the top level of ChatScript is:
g++ -lpthread -lrt -funsigned-char src/*.cpp -O2 -oLinuxChatScript 2>err.txt


  [ # 2 ]

Thank you for your reply. Wasn’t sure on how to correctly compile the code.

It seems that it still is not compiling even with the command you supplied. The output file “LinuxChatScript” is not being created. Here are the contents of err.txt.

Thank you for your time.


  [ # 3 ]

Yes, I can see you are not getting a compile w/o errors, hence no link.

I have seen the compile errors you got recently on another system.. and changed that source.

I will try to upload a new version in the next day.


  [ # 4 ]

Would appreciate that!

Thank you for your support and dedication!


  [ # 5 ]

new version up in sourceforge.

Ignore the warning messages about synsets as it starts up.


  [ # 6 ]

It’s working now, thanks! Had to remove the “-lrt” since Mac OS doesn’t seem to have librt. But the server has started fine, apart from the warning messages about synsets you mentioned.

Thanks again


  [ # 7 ]

Right.. there is a top level folder called MACHOS which stands for the OS of Mac (MACH)
and it has that correct build line.

I will figure out the synset complaints some time and fix those.


  [ # 8 ]

Didn’t notice the MACHOS folder. Are the synset complaints something to worry about?


  [ # 9 ]

no worries.

I keep strengthening the self-checking and validation capabilities of the system.
Then I discover “bugs” that have been there all along.
The system functions just fine.  Maybe a few neurons in the brain aren’t functioning perfectly but that doesn’t create a real problem. And those synsets are SO UNLIKELY to be used in a chatbot, flaws in their dictionary entries are of no concern. When I have the time, I will pin them down and fix them.


  [ # 10 ]
Bruce Wilcox - Apr 5, 2012:

Maybe a few neurons in the brain aren’t functioning perfectly but that doesn’t create a real problem.

Liked that analogy! :D



  [ # 11 ]

In my case the LinuxChatscript does get created, but when I run it I get the following error:

ChatScript Version 5.53a 64 bit MACH compiled Aug 21 2015 18:50:09
Unable to read dictionarySystem.h
Missing 37 word files
read 0 raw words
WordNet: dict=50003 fact=51 stext=4340
Error(2) opening LIVEDATA/ENGLISH
  Dictionary building disabled.

======== Began server 5.53a compiled Aug 21 2015 18:50:09 on port 1024 at Fri Aug 21 19:04:43 2015 serverlog:1 userlog: 1
Server ready - logfile:LOGS/serverlog1024.txt serverLog:1 userLog:1



  [ # 12 ]

You are not within the top level CS directory while executing the program. It reads stuff relative to that.


  login or register to react